Hint: Hive 0.8.1.1 on AWS – avoid a regression bug

Update your AWS EMR ruby client if you are using it. It has been updated just a week ago. I tried in vain to use the latest Hive version on AWS (0.8.1.1). It turns out there is a bug in the (old) script that ignores your –hive-versions parameter under some circumstances and installs Hive 0.7.1.3 instead. It happens only in some situations (for me when I added some bootstrap actions) and without an error message.

Leave a Reply